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    CSOM - No Access error when verifying permissions

    Issue

    When verifying synchronization account permissions in EPM Pulse user receives an error message:

    CSOM - No Access; OData - Success 
    NOTE: In case of such error data synchronizations for your PWA will be failing 

    Cause

    In order to perform data synchronization EPM Pulse uses the synchronization account to access data from PWA. 

    CSOM No Access error occurs in case synchronization account is not a member of the default Administrators security group in the PWA. 

    Full list of permissions required for synchronization account can be found here: Data Synchronization in EPM Pulse for Project Online

    Solution

    1. The synchronization account needs to be added to the default Administrators security group in the PWA:

    • navigate to your PWA » PWA Settings » Manage Users:
    • in the opened page click on the user name, whose account is used in EPM Pulse;
    • scroll down to the Security Groupssection and add Administrators group to the window on the right and save the changes:
    • navigate to EPM Pulse and click Verify button once again. You should now receive positive message

    2. For connections to Project Online PWAs the error might not be caused by the lack of Administrator privileges. It occurs intermittently and so far we at FluentPro discovered, that logging out and logging in to PWA helps to resolve the error. 

    In case of any issues submit a support request at support@fluentpro.com.

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