FluentPro Help Center

What do you need help with?

    Sorry, we didn't find any relevant articles for you.

    Send us your queries using the form below and we will get back to you with a solution.


    Hardware and Software requirements for Standalone installation

    In this article you will find hardware and software requirements for Integration Hub Standalone deployment.

    Hardware requirements

    Small deployment

    The following are the recommended hardware requirements for small deployments.  Recommended servers: 

    • Server 1: All-in-One box (Job processing, web, SQL) 

    Minimum hardware requirements for an All-in-One server.

    HW component
    Minimum requirement

    Processor

    64-bit, 2 cores

    RAM

    4 GB

    Hard disk

    RAID1 120 GB 

    Medium deployment

    The following are the recommended hardware requirements for medium deployments.  Recommended servers:

    • Server 1: Job Processing and Web Role 
    • Server 2: SQL Server 

    Minimum hardware requirements for Job Processing and Web Role server.

    HW component
    Minimum requirement

    Processor

    64-bit, 2 cores

    RAM

    4 GB

    Hard disk

    80 GB

    Minimum hardware requirements for SQL Server 

    HW component
    Minimum requirement

    Processor

    64-bit, 4 cores

    RAM

    8 GB

    Hard disk

    80 GB  System drive RAID1 100 GB SQL data drive

    Large deployment

    The following are the recommended hardware requirements for large deployments.  Recommended servers: 

    • Server 1: Web Role 
    • Server 2: Job Processing 
    • Server 3: SQL Server 

    Minimum hardware requirements for Web Role Server 

    HW component
    Minimum requirement

    Processor

    64-bit, 2 cores

    RAM

    2 GB

    Hard disk

    80 GB

    Minimum hardware requirements for Job Processing Server 

    HW component
    Minimum requirement

    Processor

    64-bit, 4 cores

    RAM

    8 GB

    Hard disk

    80 GB

    Minimum hardware requirements for SQL Server 

    HW component
    Minimum requirement

    Processor

    64-bit, 4 cores

    RAM

    12 GB

    Hard disk

    Please refer to this article  Estimated warehouse database growth: 20GB/month

    Software requirements

    Operating System The 64-bit edition of:
    Minimum: Windows Server 2008 R2 SP1 Standard, Enterprise, or Datacenter
    Recommended: Windows Server 2016 Standard or Datacenter
    SQL Server The 64-bit edition of:
    Minimum: Microsoft SQL Server 2012 SP1 Web, Standard or Enterprise
    Recommended: Microsoft SQL Server 2016 SP2 Web, Standard or Enterprise
    SQL Server mixed authentication mode must be enabled.
    Information about SQL Server requirements can be found here

    DNS requirements

    Integration Hub On-Premises user interface uses a separate site to operate.  A new DNS record (type A) in your Domain pointing to IP of the server, where you are planning to install Integration Hub is strongly recommended.
    Also, please make sure that Firewall does not block site access.

    List of Windows components that are required to run Integration Hub On-Premises Edition instance:

    Component
    Requirements
    Web Server (IIS) role Based on IIS 7.5 or higher.
    Minimum required components:
    1. Common HTTP Components
    - Default Document
    - HTTP Errors
    - Static Content
    2. Health and Diagnostic
    - HTTP Logging
    3. Performance
    - Static Content Compression
    4. Security
    - Request Filtering
    - Windows Authentication
    6. Application Development
    - .NET Extensibility 4.5
    - ASP.NET 4.5
    - ISAPI Extensions
    - ISAPI Filters
    SSL Certificate Integration Hub On-Premises Edition website requires HTTPS endpoint. SSL certificate can be Self-Signed or obtained from Certificate Authority center.
    .NET Framework .NET 4.5.1 or higher is a requirement for Integration Hub Job Processor service.
    .NET 4.0 or higher is a requirement for Integration Hub web site
    .NET 4.7.2 is a requirement for Integration Hub version 1.10.0.1973 or higher
    Windows PowerShell Windows PowerShell 3.0 or higher is required to execute configuration scripts


    Was this article helpful?

    Table of contents

      Still can't find what you're looking for?

      Contact Support
      Back To Top